CnPack Forum


 
Subject: Access Violation on Seattle
delphichem
普通灌水员
Rank: 2



UID 34626
Digest Posts 0
Credits 58
Posts 20
点点分 58
Reading Access 10
Registered 2007-12-23
Status Offline
Post at 2015-9-7 19:52  Profile | Blog | P.M. 
Access Violation on Seattle

Hi,

I can't run Seattle10 after installing CNPack.
Tested versionCnWizards_1.0.8.763_Unstable.exe and version andCnWizards_1.0.8.764_Unstable.exe.

I get the same error and Delphi don't open the error is repeated after clicking on ok

The first error apear after CNPack is shown on Delphi Splash screen, then it follow the second blanc dialog, when clicking Ok, the second box is closed, and when it try to close de first dialogbox, it reapear.

Can you please fix this, I can't work without CNPack


Image Attachment: CNPack.JPG (2015-9-7 19:52, 22.85 K)

Top
Passion (LiuXiao)
管理员
Rank: 9Rank: 9Rank: 9


UID 359
Digest Posts 19
Credits 6720
Posts 3538
点点分 6720
Reading Access 102
Registered 2004-3-28
Status Offline
Post at 2015-9-7 23:24  Profile | Blog | P.M. 
Oh, serious problem.
Top
delphichem
普通灌水员
Rank: 2



UID 34626
Digest Posts 0
Credits 58
Posts 20
点点分 58
Reading Access 10
Registered 2007-12-23
Status Offline
Post at 2015-9-15 03:33  Profile | Blog | P.M. 
Hi,
By deleting CnPack components, the problem is solved.
Top
Passion (LiuXiao)
管理员
Rank: 9Rank: 9Rank: 9


UID 359
Digest Posts 19
Credits 6720
Posts 3538
点点分 6720
Reading Access 102
Registered 2004-3-28
Status Offline
Post at 2015-9-15 15:14  Profile | Blog | P.M. 
I know but I can't reproduce this problem in my workstation.
Top
delphichem
普通灌水员
Rank: 2



UID 34626
Digest Posts 0
Credits 58
Posts 20
点点分 58
Reading Access 10
Registered 2007-12-23
Status Offline
Post at 2015-9-15 17:17  Profile | Blog | P.M. 
I'was trying to compile an older source before the officiel support of Seattle10, so I install CnPack components to be able to compile CnWizard.
Ofcource that, does'nt function, so I wait until un official version is realized, but I forget to uninstall dclCnPack from my component palette.
By doing that, CnWizards fonction correctly.

Thanks Passion, and sorry
Top
ma1999
新警察
Rank: 1



UID 2123
Digest Posts 0
Credits 19
Posts 8
点点分 19
Reading Access 10
Registered 2006-4-21
Status Offline
Post at 2015-9-16 03:24  Profile | Blog | P.M. 
Same problem

Sorry, I get the same problem (or similar?).
Windows 10, Seattle, only C++ installed.
With Delphi and C++ installed (other test machine) no problem.

Exception in same bpl, same adress.

No cn*.dll except cnwizards installation.

[ Last edited by  ma1999 at 2015-9-18 05:04 ]
Top
Passion (LiuXiao)
管理员
Rank: 9Rank: 9Rank: 9


UID 359
Digest Posts 19
Credits 6720
Posts 3538
点点分 6720
Reading Access 102
Registered 2004-3-28
Status Offline
Post at 2015-9-17 09:37  Profile | Blog | P.M. 
Oh, maybe CnPack Component Package causes this problem, not CnWizards. I'll check it.
Top
ma1999
新警察
Rank: 1



UID 2123
Digest Posts 0
Credits 19
Posts 8
点点分 19
Reading Access 10
Registered 2006-4-21
Status Offline
Post at 2015-9-18 05:06  Profile | Blog | P.M. 
Sorry,
only cnwizards installed !
No cnpack

(gave wrong name since directory above cnwizards is called cnpack...)
Top
Passion (LiuXiao)
管理员
Rank: 9Rank: 9Rank: 9


UID 359
Digest Posts 19
Credits 6720
Posts 3538
点点分 6720
Reading Access 102
Registered 2004-3-28
Status Offline
Post at 2015-9-18 05:37  Profile | Blog | P.M. 
I've not tried only with C++Builder. I'll check it.
Top
stefang2
新警察
Rank: 1



UID 241465
Digest Posts 0
Credits 13
Posts 6
点点分 13
Reading Access 10
Registered 2015-9-29
Status Offline
Post at 2015-9-29 19:57  Profile | Blog | P.M. 
The same happens to me as well, but only on one of three different PCs.
Might this be related to a language mismatch? The PC, where the same exception is thrown, has an englisch Windows 7x64, a german Delphi X and likewise german or english CNPack (I've tried both).
All other PCs, where this does not happen, have matching languages (all german).
Top
Passion (LiuXiao)
管理员
Rank: 9Rank: 9Rank: 9


UID 359
Digest Posts 19
Credits 6720
Posts 3538
点点分 6720
Reading Access 102
Registered 2004-3-28
Status Offline
Post at 2015-9-30 10:03  Profile | Blog | P.M. 
I still have no clue about it.
Top
stefang2
新警察
Rank: 1



UID 241465
Digest Posts 0
Credits 13
Posts 6
点点分 13
Reading Access 10
Registered 2015-9-29
Status Offline
Post at 2015-9-30 17:08  Profile | Blog | P.M. 
Would it make sense to run a debug build with extended logging to find the problem?
Top
Passion (LiuXiao)
管理员
Rank: 9Rank: 9Rank: 9


UID 359
Digest Posts 19
Credits 6720
Posts 3538
点点分 6720
Reading Access 102
Registered 2004-3-28
Status Offline
Post at 2015-9-30 23:24  Profile | Blog | P.M. 
Debug version is here: http://www.cnpack.org/downbuilds.php?kind=debug&lang=en

Hope it can help more.
Top
stefang2
新警察
Rank: 1



UID 241465
Digest Posts 0
Credits 13
Posts 6
点点分 13
Reading Access 10
Registered 2015-9-29
Status Offline
Post at 2015-10-1 19:08  Profile | Blog | P.M. 
Here's a debug log, but it doesn't show any caught exception.


Attachment: cnpack.exception.on.DXSeattle.Start.zip (2015-10-1 19:08, 16.9 K)
Download count 437
Top
ma1999
新警察
Rank: 1



UID 2123
Digest Posts 0
Credits 19
Posts 8
点点分 19
Reading Access 10
Registered 2006-4-21
Status Offline
Post at 2015-10-5 17:15  Profile | Blog | P.M. 
Tried with debugger version, nothing caught.
But C++ builder still dies with above errors
Top
methosraven
新警察
Rank: 1



UID 243655
Digest Posts 0
Credits 2
Posts 1
点点分 2
Reading Access 10
Registered 2015-10-12
Status Offline
Post at 2015-10-12 18:37  Profile | Blog | P.M. 
Hi!

I have the same problem.
Is there any solution?

The error appears on my computer (Win 8.1 x64), but on my collegue's computer it works (Windows 7 Prof x64)
Top
AntiUser
新警察
Rank: 1



UID 245388
Digest Posts 0
Credits 2
Posts 1
点点分 2
Reading Access 10
Registered 2015-10-25
Status Offline
Post at 2015-10-25 02:39  Profile | Blog | P.M. 
У меня появлялась такая же ошибка. Разбор полетов показал, что проблема была в том, что я экспортировал ветку реестра из предыдущей версии Delphi (мне просто лень было настраивать заново). Именно экспорт/импорт ветки
HKEY_CURRENT_USER\Software\Embarcadero\BDS\17.0\Editor\Options\Known Editor Enhancements
приводил к появлению этого АВ.

Т.е. еще раз понятнее
Я брал из старой дельфи ветку реестра содержащую настройки редактора (HKEY_CURRENT_USER\Software\Embarcadero\BDS\17.0\Editor), менял в .reg файле версию среды (в моем случае 12.0 на 17.0) и импортировал снова. Таким образом в новой среде у меня становился настроенный редактор, но появлялось AV.
Удалив из .reg файла секцию
HKEY_CURRENT_USER\Software\Embarcadero\BDS\17.0\Editor\Options\Known Editor Enhancements
и импортировав снова снова (на чистый редактор) АВ исчезла.


------------
Если кто может переведите этот текст этим не русским.
А ну как поможет.
Top
stefang2
新警察
Rank: 1



UID 241465
Digest Posts 0
Credits 13
Posts 6
点点分 13
Reading Access 10
Registered 2015-9-29
Status Offline
Post at 2015-10-25 23:41  Profile | Blog | P.M. 


QUOTE:
Originally posted by &lt;i&gt;AntiUser&lt;/i&gt; at 2015-10-25 02:39&lt;br /&gt;<br />
У меня появлялась такая же ошибка. Разбор полетов показал, что проблема была в том, что я экспортировал ветку??...

Could you translate that into english please?!
Here are other people in this forum that do NOT speak russian!
Top
Passion (LiuXiao)
管理员
Rank: 9Rank: 9Rank: 9


UID 359
Digest Posts 19
Credits 6720
Posts 3538
点点分 6720
Reading Access 102
Registered 2004-3-28
Status Offline
Post at 2015-10-26 10:07  Profile | Blog | P.M. 
Using Google Translate:

I have the same error appeared. Debriefing showed that the problem was that I exported registry branch from a previous version of Delphi (I'm just too lazy to re-configure). This import / export branch
HKEY_CURRENT_USER \ Software \ Embarcadero \ BDS \ 17.0 \ Editor \ Options \ Known Editor Enhancements
It led to the appearance of the AB.
Ie again clearer
I took out the old Delphi registry branch containing the editor settings (HKEY_CURRENT_USER \ Software \ Embarcadero \ BDS \ 17.0 \ Editor), changed in the version of the .reg file (in my case 12.0 17.0) and imported again. Thus, in the new environment, I became editor-tuned, but there is AV.
By removing from the .reg file section
HKEY_CURRENT_USER \ Software \ Embarcadero \ BDS \ 17.0 \ Editor \ Options \ Known Editor Enhancements
and imported back again (on net Editor) AB disappeared.
Top
stefang2
新警察
Rank: 1



UID 241465
Digest Posts 0
Credits 13
Posts 6
点点分 13
Reading Access 10
Registered 2015-9-29
Status Offline
Post at 2015-10-26 16:52  Profile | Blog | P.M. 
I can confirm that the error is indeed solved now! http://www.excellenthosting.tk/images/smilies/lol.gif

You have to remove the entry "CnPack.BufferList" only ONCE from the registry path "HKEY_CURRENT_USER \ Software \ Embarcadero \ BDS \ 17.0 \ Editor \ Options \ Known Editor Enhancements", before starting Delphi.
You might have to renumber the "priority" properties in all remaining entries in the path! It must be an ascending list starting with Priority=0, otherwise Delphi will complain about a list with index out of bound.
Once Delphi is started, CNPack will re-add the entry, but from now on Delphi starts just fine, the entry must not be removed again.

All thanks go to Russia!
Top
 




All times are GMT++8, the time now is 2023-9-27 17:44

    本论坛支付平台由支付宝提供
携手打造安全诚信的交易社区 Powered by Discuz! 5.0.0  © 2001-2006 Comsenz Inc.
Processed in 0.009206 second(s), 8 queries , Gzip enabled

Clear Cookies - Contact Us - CnPack Website - Archiver - WAP