Board logo

Subject: Access Violation on Seattle [Print This Page]

Author: delphichem    Time: 2015-9-7 19:52     Subject: Access Violation on Seattle


I can't run Seattle10 after installing CNPack.
Tested versionCnWizards_1.0.8.763_Unstable.exe and version andCnWizards_1.0.8.764_Unstable.exe.

I get the same error and Delphi don't open the error is repeated after clicking on ok

The first error apear after CNPack is shown on Delphi Splash screen, then it follow the second blanc dialog, when clicking Ok, the second box is closed, and when it try to close de first dialogbox, it reapear.

Can you please fix this, I can't work without CNPack

Image Attachment: CNPack.JPG (2015-9-7 19:52, 22.85 K) / Download count 548

Author: Passion    Time: 2015-9-7 23:24

Oh, serious problem.
Author: delphichem    Time: 2015-9-15 03:33

By deleting CnPack components, the problem is solved.
Author: Passion    Time: 2015-9-15 15:14

I know but I can't reproduce this problem in my workstation.
Author: delphichem    Time: 2015-9-15 17:17

I'was trying to compile an older source before the officiel support of Seattle10, so I install CnPack components to be able to compile CnWizard.
Ofcource that, does'nt function, so I wait until un official version is realized, but I forget to uninstall dclCnPack from my component palette.
By doing that, CnWizards fonction correctly.

Thanks Passion, and sorry
Author: ma1999    Time: 2015-9-16 03:24     Subject: Same problem

Sorry, I get the same problem (or similar?).
Windows 10, Seattle, only C++ installed.
With Delphi and C++ installed (other test machine) no problem.

Exception in same bpl, same adress.

No cn*.dll except cnwizards installation.

[ Last edited by  ma1999 at 2015-9-18 05:04 ]
Author: Passion    Time: 2015-9-17 09:37

Oh, maybe CnPack Component Package causes this problem, not CnWizards. I'll check it.
Author: ma1999    Time: 2015-9-18 05:06

only cnwizards installed !
No cnpack

(gave wrong name since directory above cnwizards is called cnpack...)
Author: Passion    Time: 2015-9-18 05:37

I've not tried only with C++Builder. I'll check it.
Author: stefang2    Time: 2015-9-29 19:57

The same happens to me as well, but only on one of three different PCs.
Might this be related to a language mismatch? The PC, where the same exception is thrown, has an englisch Windows 7x64, a german Delphi X and likewise german or english CNPack (I've tried both).
All other PCs, where this does not happen, have matching languages (all german).
Author: Passion    Time: 2015-9-30 10:03

I still have no clue about it.
Author: stefang2    Time: 2015-9-30 17:08

Would it make sense to run a debug build with extended logging to find the problem?
Author: Passion    Time: 2015-9-30 23:24

Debug version is here:

Hope it can help more.
Author: stefang2    Time: 2015-10-1 19:08

Here's a debug log, but it doesn't show any caught exception.

Attachment: (2015-10-1 19:08, 16.9 K) / Download count 517
Author: ma1999    Time: 2015-10-5 17:15

Tried with debugger version, nothing caught.
But C++ builder still dies with above errors
Author: methosraven    Time: 2015-10-12 18:37


I have the same problem.
Is there any solution?

The error appears on my computer (Win 8.1 x64), but on my collegue's computer it works (Windows 7 Prof x64)
Author: AntiUser    Time: 2015-10-25 02:39

У меня появлялась такая же ошибка. Разбор полетов показал, что проблема была в том, что я экспортировал ветку реестра из предыдущей версии Delphi (мне просто лень было настраивать заново). Именно экспорт/импорт ветки
HKEY_CURRENT_USER\Software\Embarcadero\BDS\17.0\Editor\Options\Known Editor Enhancements
приводил к появлению этого АВ.

Т.е. еще раз понятнее
Я брал из старой дельфи ветку реестра содержащую настройки редактора (HKEY_CURRENT_USER\Software\Embarcadero\BDS\17.0\Editor), менял в .reg файле версию среды (в моем случае 12.0 на 17.0) и импортировал снова. Таким образом в новой среде у меня становился настроенный редактор, но появлялось AV.
Удалив из .reg файла секцию
HKEY_CURRENT_USER\Software\Embarcadero\BDS\17.0\Editor\Options\Known Editor Enhancements
и импортировав снова снова (на чистый редактор) АВ исчезла.

Если кто может переведите этот текст этим не русским.
А ну как поможет.
Author: stefang2    Time: 2015-10-25 23:41

Originally posted by &lt;i&gt;AntiUser&lt;/i&gt; at 2015-10-25 02:39&lt;br /&gt;<br />
У меня появлялась такая же ошибка. Разбор полетов показал, что проблема была в том, что я экспортировал ветку??...

Could you translate that into english please?!
Here are other people in this forum that do NOT speak russian!
Author: Passion    Time: 2015-10-26 10:07

Using Google Translate:

I have the same error appeared. Debriefing showed that the problem was that I exported registry branch from a previous version of Delphi (I'm just too lazy to re-configure). This import / export branch
HKEY_CURRENT_USER \ Software \ Embarcadero \ BDS \ 17.0 \ Editor \ Options \ Known Editor Enhancements
It led to the appearance of the AB.
Ie again clearer
I took out the old Delphi registry branch containing the editor settings (HKEY_CURRENT_USER \ Software \ Embarcadero \ BDS \ 17.0 \ Editor), changed in the version of the .reg file (in my case 12.0 17.0) and imported again. Thus, in the new environment, I became editor-tuned, but there is AV.
By removing from the .reg file section
HKEY_CURRENT_USER \ Software \ Embarcadero \ BDS \ 17.0 \ Editor \ Options \ Known Editor Enhancements
and imported back again (on net Editor) AB disappeared.
Author: stefang2    Time: 2015-10-26 16:52

I can confirm that the error is indeed solved now!

You have to remove the entry "CnPack.BufferList" only ONCE from the registry path "HKEY_CURRENT_USER \ Software \ Embarcadero \ BDS \ 17.0 \ Editor \ Options \ Known Editor Enhancements", before starting Delphi.
You might have to renumber the "priority" properties in all remaining entries in the path! It must be an ascending list starting with Priority=0, otherwise Delphi will complain about a list with index out of bound.
Once Delphi is started, CNPack will re-add the entry, but from now on Delphi starts just fine, the entry must not be removed again.

All thanks go to Russia!
Author: Passion    Time: 2015-10-26 17:05

Maybe the same root cause with this? ... &extra=page%3D1
Author: stefang2    Time: 2015-10-26 20:54

What happened to my reply that the problem could be fixed with deleting the reg key?
I got a message that it is checked by the admin first, but it was never actually posted.

[ Last edited by  stefang2 at 2015-10-26 20:58 ]
Author: Passion    Time: 2015-11-2 11:07

I guess this AV maybe caused by the sequence of Key Mapping between CnPack and Castiala. but don't know why.
Author: Passion    Time: 2015-11-24 17:01

The latest nightly-build version of CnWizards 798 is here for downloading:

It add a check and Hint Dialog sequence of Key Mapping during Starting-Up. We can follow the steps to fix.

Seems can't fix it in CnWizards.

Welcome to CnPack Forum ( Powered by Discuz! 5.0.0