CnPack Forum


 
didiergm
新警察
Rank: 1



UID 42151
Digest Posts 0
Credits 6
Posts 2
点点分 6
Reading Access 10
Registered 2009-4-8
Status Offline
Post at 2009-4-8 02:45  Profile | Blog | P.M. 
CPU usage

Hello and congratulations for your set of enhancements. It is truly excellent.

I use in under D2007 and it makes a fantastic difference.

I do have an issue though with the general speed and CPU usage. After a couple of hours, everything (code completion most notably) slows down and the CPU usage starts to climb, from a normal 15% while I am doing nothing to 30-40%, code completion needs 4-5 seconds to react and the IDE stall while I am typing.

Closing the project on which I am working (which is NOT big: there is one form and 5 smallish units) does not help at all; I have to close delphi down completely.

In the list of units, there is one massive unit, though: MSHTML_TLB (this is because I use the tWebBrowser and it defines the interface), this as over 340000 lines ! Trying to browse to the end of the file uses 2 cores at 90% each! and it takes several minutes to "come back to life".  Note also that I am running in Windows XP inside a virtual machine (Vmware server). The VM has 768MB RAM and 2 cores allocated (out of 4 cores: I have a Intel Q6660)

Is there a way to exclude a unit for all processing by your pack ? I do not need the autocompletion on this massive unit. and in fact, it is never opened in the IDE as natively D2007 has trouble with such a large file, although not to that extent.

Note that it is not meant as a criticism as I really enjoy using your factastic pack.

thanks for your help

Regards

Didier
Top
Passion (LiuXiao)
管理员
Rank: 9Rank: 9Rank: 9


UID 359
Digest Posts 19
Credits 6684
Posts 3521
点点分 6684
Reading Access 102
Registered 2004-3-28
Status Offline
Post at 2009-4-13 16:12  Profile | Blog | P.M. 
The CPU usage problem under BDS were also reported by other friends before. But seems related to IDE internal exceptions and not so easy to re-produce and fix, so now still exists. We're also trying to fix it.

Now code input helper does not have options to massive unit, only Source Highlight has this option that do not parse files more than 25000 lines (Line count can be customized).

I think to this big unit, every thing maybe slow down, not only the input helper. Could you try if disable our input helper and use IDE's Code insight itself, is it so slow, too or not?
Top
didiergm
新警察
Rank: 1



UID 42151
Digest Posts 0
Credits 6
Posts 2
点点分 6
Reading Access 10
Registered 2009-4-8
Status Offline
Post at 2009-4-26 18:20  Profile | Blog | P.M. 
Passion,

Sorry I did not answer earlier I was not using Delphi for a bit. Source highlight is set to 10000 lines in my machine;

Delphi's own code insight is slow too.

I think may be (if possible) having a project wide setup to ignore some files across the board would be great but I realise it might be very specific to my needs and not widely needed.

To be fair, it is slow but still quite usable; Some other products (commercial) crawl to a halt; especially when, like me I have a couple of instances  Delphi opened at the same time;

to reproduce, it is fairly easy (if you want a very large file) you can import the lib for the tWebbrowser; this will produce a file of over 300000 lines, that should be plenty to play with

Thanks again for the very good work

Didier
Top
omihaz
新警察
Rank: 1



UID 43195
Digest Posts 0
Credits 9
Posts 3
点点分 9
Reading Access 10
Registered 2009-8-23
Status Offline
Post at 2009-8-23 09:11  Profile | Blog | P.M. 
I have same trouble. With big source files my IDE very slow. Typing is slow too. Selecting text slow too.

I have:
Delphi? 2007 for Win32?  Version 11.0.2902.10471
CnPack 0.9.3.534 Build 2009.08.01

My hardware is good: AMD5600X2, 2GB RAM

BUT, all problems go out, when you start debug project (Run application - F9). When application running, IDE editor work very fast and all good.

I think problem with parsing source code, if:
- Source code too big
- Source code have many used Units

This problem exists without CnPack. IDE have perfomance problem.

Can add tool, how еmulating Run state editor (disable parsing, etc). And enable code completion only hot-keys? Or any suggestion?

       
Please help. Very please, I beg! I can not work so slowly!
Top
Passion (LiuXiao)
管理员
Rank: 9Rank: 9Rank: 9


UID 359
Digest Posts 19
Credits 6684
Posts 3521
点点分 6684
Reading Access 102
Registered 2004-3-28
Status Offline
Post at 2009-8-24 14:33  Profile | Blog | P.M. 
If files are too big. No good way to make it fast, except disable Source Highlight and Code Input Helper and Procedure Toolbar.
Source Highlight and Code Input Helper both can be set to just work when pressing hot-key. Please check them in settingsdialog?
Top
omihaz
新警察
Rank: 1



UID 43195
Digest Posts 0
Credits 9
Posts 3
点点分 9
Reading Access 10
Registered 2009-8-23
Status Offline
Post at 2009-9-2 01:51  Profile | Blog | P.M. 
Thanks, Passion. If disable - works normal.
Top
 




All times are GMT++8, the time now is 2022-8-20 14:15

    本论坛支付平台由支付宝提供
携手打造安全诚信的交易社区 Powered by Discuz! 5.0.0  © 2001-2006 Comsenz Inc.
Processed in 0.013794 second(s), 8 queries , Gzip enabled

Clear Cookies - Contact Us - CnPack Website - Archiver - WAP