CnPack Forum » CnWizards IDE Wizards » [D7] [8.2.356] Delay of about 15 seconds when reaching first breakpoint

2008-2-8 18:27 Edelcom
[D7] [8.2.356] Delay of about 15 seconds when reaching first breakpoint


Ever since CnPack has automatically installed version 8.2.356, I get a more than 15 seconds delay when the first breakpoint is reached in debug mode.
After this the message 'Source code is changed, do you want to recompile the project' message is displayed.

Steps to reproduce:
- set a breakpoint anywhere in your source
- run the project F9
When the breakpoint is reached I get the above freeze and question.

It might not be CnPacks, but, as far as I can remember, this component is the only one which has been changed in my environment the last few weeks.

Anyone any idea ?


p.s. Great product !!!

2008-2-14 09:23 Passion
Thanks for your report. It's a tricky problem. We just have no clue to investigate it for it does not reproduce in our environment.

If you disable CnWizards from start menu and this problem can disappear, it should be a bug of CnWizards.

Could you help us to "debug" it?

2008-3-12 22:57 Edelcom

It certainly is CnPack which is cuasing the problem.

If I disable CnPack, the delay is not present anymore.

I attached the zipped debug file.

[u]Steps taken:[/u]

Started the DebugViewer
Started Delphi - my project was automatically loaded
Set a breakpoint
Run my program
Reached the breakpoint
The prompt which asked me to save my changed source was presented, but stepping through it, was immediatly !
I stopped my program.
Typed a space in my source and ran the program again.
The breakpoint was reached a second time
Once again the prompt was asked if I would like to save my changed source code, but after answering Yes, the delay of 10 seconds (or more) wa present now.
Stopped my program.
Stopped Delphi

Zipped the results.

Now the prompt to save my source should not occur because Delphi should save changed source.

I hope you find the problem, because duing development such a delay is very, very annoying.

Thanks for you help.

2008-3-12 23:57 Passion
Thanks. we'll check it.:handshake

2008-3-23 00:56 Passion
After some investigation, I think the prompt to save your source, which should not occur, comes from our Version Enhancement Wizard.

It can auto add version number to project after compiling.

Now I do not have a clue about where the delay comes from. But could you disable version enhancement wizard in CnWizards' setting dialog if you did not need auto version number increment? Maybe it can do some help to avoid the delay.


2008-3-29 21:44 Edelcom
Delay is gone ... thanks

You are correct: disabling the Version Enhancement Wizard removes the delay completely.

Thanks for the support: it is really appreciated here from the other end of the globe   :)

Any new features planned for your marvelous components ?

页: [1]

Powered by Discuz! Archiver 5.0.0  © 2001-2006 Comsenz Inc.